Forum: Geo Job Manager

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Job Manager premium extension please open a new premium support ticket.

[Resolved]Address autocomplete broken

Home Forums Geo Job Manager Address autocomplete broken

This topic contains 6 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 12 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #49510

    Christian Habenicht
    Participant

    Hi!

    hope, this is the right thread for my problem:

    i have a clean install of WP / WP Job Manager / your plugin.

    If i create / edit a job i have no autocomplete in at the location field. And in the Chrome-Console i got the error: “You have included the Google Maps API multiple times on this page. This may cause unexpected errors.”.

    i tried to deactivate the autocomplete in your plugin settings and it doesn’t help. If i enter a city-name and save the post the city and the location data will be added correctly at the custom fields. But i wish to use the autocomplete.

    #49514

    Eyal Fitoussi
    Keymaster

    Hi christian,
    I moved your question to its own topic.

    Looks like there is a conflict with another plugin or with the theme that your are using.

    The error you are getting cause when including Google API multiple times.

    1) Are you using another maps plugin ?

    2) Which theme are you using?

    Thanks,

    #49517

    Christian Habenicht
    Participant

    ups, sorry for repeating my follow at another thread!

    i don’t use any other plugins yet.

    i use enfold theme from kriesi.

    thank you! 🙂

    #49518

    Christian Habenicht
    Participant
    This reply has been marked as private.
    #49546

    Eyal Fitoussi
    Keymaster

    Thanks for the info.

    Looks like the theme also load Google API to be used with the Google Map widget. That most likely the cause for the conflict.

    You can try to disable the API call made by the WP job Manager Geolocation using the code below ( in the functions.php file of the theme ):

    This might remove the JS error but the address autocomplete might still not work, that is depend on the API call made by the theme and if it include the Places library.

    If the script does not work try contacting the developers of the theme and asked them if it is possible to disable the Google API call made by the theme using a filter or so since the plugin already includes the API.

    let me know if that helps.

    #49593

    Christian Habenicht
    Participant

    hey!

    thank you. this hint helps.
    while enfold is so popular, here the filter for disabling the G’API:

    look at: http://www.kriesi.at/support/topic/disable-google-maps-api-call-in-backend/

    it is resolved.

    #49597

    Eyal Fitoussi
    Keymaster

    Beautiful!

    Thank you for posting the solution.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.