Forum: Xprofile Fields

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Xprofile Fields premium extension please open a new premium support ticket.

[Resolved]Country search not finding members

Home Forums Xprofile Fields Country search not finding members

Tagged: ,

This topic contains 1 reply, has 2 voices, and was last updated by  Eyal Fitoussi 4 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43136

    Craig Moser
    Participant

    I am having an issue that my Location search on my buddypress site. It is not finding the country when searched. If you search for city, state, zip everything comes up prefect but country always comes back not finding members.

    Here is the link to the form.

    The majority of coaches/members are from the US, but there are a few from Canada. For example this Coach.

    Any suggestions?

    #43238

    Eyal Fitoussi
    Keymaster

    Hi Craig,
    GEO my WP searches for locations based on coordinates and not within the state or country that you enter. So if you enter “US” only for example GEO my WP geocodes “US” and get the lat/long of the point representing the US on the map. Then it searches for locations near this point within the radius entered. That is why you don’t get any results.

    The only way at the moment to overcome this is to create a custom states or countries dropdown that visitors can choose from. Once they Choose GEO my WP will need to search the database based on the state/country column instead of doing a proximity search.

    An example for the above ( made for post types ) can be found Filter results by state. You can create something similar for BuddyPress Members.

    I hope that helps.

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘Country search not finding members’ is closed to new replies.