Forum: Bug Reports

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support and general questions related to GEO my WP plugin and its core add-ons please use the support forum.

[Resolved]Custom Template's Not Loading

Home Forums Bug Reports Custom Template's Not Loading

This topic contains 15 replies, has 5 voices, and was last updated by  yusef_lockwood 5 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #29713

    yusef_lockwood
    Participant

    I’m following these template formats to create “update safe” custom templates:

    “/themes/mytheme/geo-my-wp/friends/search-form/myformtheme/search-form.php” and

    “/themes/mytheme/geo-my-wp/friends/search-results/myresultstheme/results.php”

    The css folders and stylesheets are in each folder as well.

    But when I go to “Search Forms” in the admin and edit my buddypress search form, I still only see “default” under the search form templates.

    Is there something I’m missing or doing wrong?

    #29728

    yusef_lockwood
    Participant

    Also of note, the custom templates do show up on the “Add-Ons” page in the admin.

    #29727

    Eyal Fitoussi
    Keymaster

    Hi Yusef,
    I am not sure if it’s a typo above or also in your folder’s name but note that in you have “search-form” in “/themes/mytheme/geo-my-wp/friends/search-form/ instead of “search-forms”.

    Please let me know if that is the issue or just a typo above.

    Thank you
    Eyal

    #29726

    Eyal Fitoussi
    Keymaster

    BTW,
    Thank you for your purchase and support 🙂

    #29725

    Yusef Mahmud-Bey
    Participant

    Sorry, the was a typo. It’s actually “search-forms”.

    I’m able to get the search results to show my template by writing a function that updates the option wppl_shortcode and changing the ‘results_template’ in the array for my form.

    However, the template isn’t shown in the WP admin.

    #29724

    Eyal Fitoussi
    Keymaster

    Hi Yusef,
    My apology but i am just going over unresolved tickets and i saw that i missed you last post here.
    Did you get it fixed or still having issues?

    #29723

    Jeff Metzger
    Participant

    Hi Eyal, I’m having the exact same issue. Great plugin aside from this hopefully minor issue.

    You can see it is loaded under the settings panel here

    https://www.dropbox.com/s/5tmtw3qyn0qufvn/Screenshot%202014-01-22%2016.02.31.png

    But it is not showing up on the search form.

    https://www.dropbox.com/s/6dv5u4mji7x2ms2/Screenshot%202014-01-22%2016.12.43.png

    Any ideas? Or any work a rounds until this gets resolved?

    #29722

    Eyal Fitoussi
    Keymaster

    Hi Jeff,
    I am currently working on the next major update of Support. Would you like to test it and same time see if it solves your issue?

    #29721

    Jeff Metzger
    Participant

    Eyal, yes I’d love to test it out.

    #29720

    Eyal Fitoussi
    Keymaster

    Please email me your email to info@geomywp.com/supports and i will send you the beta.
    Are you using any of the premium add-ons?

    #29719

    Benjamin S
    Participant

    Hi Eyal,

    so it is not possible at all to use the custom-templates feature in the current version?
    Because I just purchased your plugin together with the XProfiles-Addon and run into the same issues as the guys in the thread. No custom templates shown in the backend, only the default ones.

    Would be good if you could help me, it’s pretty important. Thanks.

    #29718

    Eyal Fitoussi
    Keymaster

    Hi Benjamin,
    I will take a look at it today and will try to provide a quick fix for you.

    #29717

    Benjamin S
    Participant

    Hi Eyal,
    ok thanks.

    #29716

    Eyal Fitoussi
    Keymaster

    Hi Benjamin,
    to fix the issue with the custom template files open the file:
    geo-my-wp/plugins/friends/includes/admin/edit-shortcode.php

    and look for the line below ( should be line 321) :

    <?php foreach ( glob(STYLESHEETPATH. '/geo-my-wp/buddypress/search-results/*', GLOB_ONLYDIR) as $dir ) { ?>

    and change the word buddypress to friends.

    #29715

    Benjamin S
    Participant

    Thanks Eyal, that worked!
    Will you implement it in the next update, so I don’t need to change it again?

    Cheers,
    Benjamin

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.