Forum: Gravity Geolocation

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Gravity Geolocation premium extension please open a new premium support ticket.

[Resolved]Enable Google Address Autocomplete on Single Line Text Field

Home Forums Gravity Geolocation Enable Google Address Autocomplete on Single Line Text Field

This topic contains 4 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #53396

    AJ
    Participant

    Hi,

    Thank you for creating this plugin. Keep up the good work. I just have a problem with one of my forms. How do I Enable Google Address Autocomplete on single line text field? Normally there is a checkbox somewhere that says, “Enable Google Address Autocomplete” on the field settings for a single line input; however, it is nowhere to be found. It used to be there when I had version 2.0 beta. But when I upgraded it went away. Also there used to be a settings section for each form that has an option to enable geolocation for the current form, but that is missing as well.

    I have created a Google Maps API key and added it to the settings page.

    I have the following versions installed:
    Gravity Forms: 2.0.3
    Gravity Forms Geolocation Add-on: 2.1.1
    Wordpress: 4.5.3

    I have two forms, and on one of the forms the single line text field has the google maps autocomplete working. However, on the second form on the single line text field it doesn’t work. Both forms used to work when I had the Version 2.0 beta installed.

    Can you please look into why the single line field doesn’t have the checkbox “Enable Google Address Autocomplete” in the settings.

    Thanks for your help in advance.

    Regards,
    Alex J

    #53411

    Eyal Fitoussi
    Keymaster

    Hello Alex,

    In version 2.0 ( final released ) the autocomplete feature was removed from the single address field. You can now simply use the “Address” field ( under the Geolocation Fields group ) as a single text field with the autocomplete features. The “Address” field has the same features as the “Single Line Text” field and can also be used as custom field.

    Also there used to be a settings section for each form that has an option to enable geolocation for the current form, but that is missing as well.

    This was removed as well. Since version 2.0 all forms have the geolocation fields enabled by default. There is no need to disable/enable it. You can choose to either use the Geolocation fields by adding them to the form or not use them at all.

    Let me know if that helps.

    #53416

    AJ
    Participant

    Hi,

    Thanks for the reply. I liked having the google autocomplete on a single line text field because I already have entries with that field. If we can get that re-implemented in a future release that would be great. But I am having problems with the address field.

    I have a gravity forms address field already, and when I checkbox “enable google address autocomplete”, the field doesn’t show on the front end. It has a display none tag. And even when I remove the display none tag, the autocomplete still doesn’t work.

    If I use the Geolocation address field, the autocomplete works good. However it doesn’t show up when using the built in address field with the autocomplete enabled.

    Thanks again for your help in advance.

    AJ

    #53426

    Eyal Fitoussi
    Keymaster

    Hi Aj,

    Please add a “Geocode” field to the form and assign the “Geocoder ID” ( dropdown menu ) of the “address” field to this Geocoder field. Then check if the autocomplete works.

    If it still doesn’t work, Can you post a link to the live form while the autocomplete feature is enabled for the built in address field? I would like to take a look.

    Thanks,

    #53887

    Eyal Fitoussi
    Keymaster

    This topic marked “Resolved” due to inactivity. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.