Forum: Exclude Members

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Exclude Members premium extension please open a new premium support ticket.

[Resolved]Exclude members filters not working

Home Forums Exclude Members Exclude members filters not working

This topic contains 5 replies, has 2 voices, and was last updated by  Matthew Rea 4 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #45283

    Matthew Rea
    Participant

    Hi, I have managed to exclude members not required by excluding by name, but other filters don’t work correctly:

    If I exclude by user role, this works with most members, but not all so I have had to exclude by name: eg. Lorraine Ann Oswald, Kenneth Day. This is on Members Locator and Members Global Map.

    Also, if I check to filter members by group on members global map, it removes everyone.

    I am using a workaround at the moment by excluding by name as the site is live, but my client is asking why these filters don’t work when they use them.

    Thanks, Matt

     

    Private Content Hidden
    #45420

    Eyal Fitoussi
    Keymaster

    Hi Matt,
    I logged into the site and tried to locate the issue but without success. This is weird, as the user is marked as contributor but when pulling the users from database based on their role these two users don’t come up.

    Is it possible to provide me with FTP access to have a “deeper” look?

    #45424

    Matthew Rea
    Participant

    Hi Eyal, details here…

    Private Content Hidden
    #45425

    Eyal Fitoussi
    Keymaster

    Thank you, I finally found the issue.

    I has the prefix ‘wp_’ hardcoded in the query that pulls the users ID based on their role but because you have a custom table prefix it didn’t work. I fixed that and it is now working.

    Give it a try and let me know if it is indeed working as expected.

    Thanks,

    #45500

    Matthew Rea
    Participant

    Hi Eyal,

    This seems to have fixed excluding by user role which is what I need for now, so thanks for that.

    I am still finding the if I try to filter by group, it removes everyone from the map.

    regards,

    Matt

    #45501

    Matthew Rea
    Participant

    Hi Eyal,

    I found that if I filtered by 5 and there were 118 results, for example, the last page with the last 3 results wouldn’t show. This has been fixed now and all results show.

    However, I am still finding that selecting to show anything other than 5 results returns a blank page.

    Will the update fix this? I have just set it to only show 5 results for now without any option to select anything else.

    Regards, Matt

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.