Forum: Geo Job Manager

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Job Manager premium extension please open a new premium support ticket.

[Resolved]Geocode Address Location is not geocoded.

Home Forums Geo Job Manager Geocode Address Location is not geocoded.

This topic contains 7 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #53535

    Andrew Bossola
    Participant

    I’m getting this error again and subsequently I can’t geocode any of the listings. I think maybe a dozen do…

    I have the overcome query limit installed but I’m not getting any errors or anything hinting to the fact that I have hit any kind of limit in the Developer’s console where that key was created.

    What is another work around on this? It works fine locally. I’ve had so many issues with all of this. Its crazy. I’m pulling my hair out.

    #53538

    Andrew Bossola
    Participant

    I tried to just export the posts from the install where it worked fine but the map doesn’t show when I import the posts. What else would need to be moved over if I do this manually? IE: where is the geocode data live?

    #53576

    Eyal Fitoussi
    Keymaster

    Hello Andrew,
    I am sorry you are having troubles again.

    The geolocation information is saved in two locations:

    I have the overcome query limit installed but I’m not getting any errors

    Are you referring to this plugin? If so, what happens when you click on “geocode address” button?

    What else would need to be moved over if I do this manually? IE: where is the geocode data live?

    The geolocation information is saved in two locations:

    1) In custom fields – this is where WP Job Manager plugin saves the geolocation information after geocoding a location.

    2) In custom table in database – this is where Job Manager Geolocation add-on saves the geolocation information to have a better performance when doing a proximity search.

    SO, when importing the locations you need to make sure that custom fields are being imported as well. This way the geolocation information that is save in the custom fields will also exits in the live site. Once the importing is done you then need to navigate to the Job Geolocation Settings page and click the “Import” button. This importer will import the geolocation data from the custom fields into the geolocation custom table in database.

    #53587

    Andrew Bossola
    Participant

    If I use the plugin I can geocode them by hand but there are hundreds of listings. Its not something the client is OK with and understandably so. Can you tell me why they won’t geocode on the live site but just fine locally?

    If you could provide step by step instructions how to import just the listings and their geodata, that would help. I’m still not getting all of the listings over or they are duplicated or not geocoding. I really don’t want to give up on this. If I move them over manually, the ones that are not geocoded won’t geocode at all. I’d like to think that the plugin would work as advertised ya know? So far, nothing has really worked for me. Its been brutal. Anything you can do to help would be great. I’d really like to know why they won’t geocode on import on the live site.

    #53588

    Andrew Bossola
    Participant

    Even all of the local ones are not actually geocoding. So why wont they geocode? We’re not anywhere near our limit of queries.

    #53590

    Andrew Bossola
    Participant

    Sorry for all of the posts… so I saw where Google won’t let you post more than 125 queries at a time. That probably explains why I get to 140 and it stops. I broke the import into chunks of 100 and I think it worked!!!! I hope this helps others.

    #53593

    Eyal Fitoussi
    Keymaster

    Hi Andrew,

    Sorry for all of the posts… so I saw where Google won’t let you post more than 125 queries at a time. That probably explains why I get to 140 and it stops. I broke the import into chunks of 100 and I think it worked!!!!

    That makes sense. When using a plugin for bulk geocoding you are kind of abusing the Google geocoding system. So when geocoding many locations at a short time Google API will throw an error and block the geocoding. There should also be a short delay, of 3 or 4 seconds, between the geocoding calls to also prevent google API from blocking it. Also, you shouldn’t geocode more than 1500 locations per 24 hours.

    And please remember, the geocoding part is done by WP Job Manager plugin and not Job Manager Geolocation add-on.

    Anyway, Thanks for posting the solution.

    #53660

    Eyal Fitoussi
    Keymaster

    This topic marked “Resolved”. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.