Forum: Gravity Geolocation

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Gravity Geolocation premium extension please open a new premium support ticket.

[Resolved]"Geocode this Field" function in gravity form not functioning

Home Forums Gravity Geolocation "Geocode this Field" function in gravity form not functioning

This topic contains 18 replies, has 2 voices, and was last updated by  solarteam 3 years, 1 month ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #52907

    solarteam
    Participant

    I recently added a new site to our multisite and tried to set up an address field in a gravity form that uses the Geocode this field and enable google address auto complete. When testing I received an error message that said: “We could not find the address you entered for the following reason: REQUEST_DENIED”

    Both the Geo Coded Address field and the Map Geolocation field do not function and return the error above. I have deactivated and reactivated the plugin on the multisite and for the individual site with no luck.

    I am using Gravity Forms Geolocation Add-on – Version 2.0-beta-8 and Geo My WP – Version 2.6.5. My license for the Geolocation add-on has expired, but this should not effect the functionality correct?

    Thanks!

    #52966

    Eyal Fitoussi
    Keymaster

    HI,
    I am now looking into this issue. As since last week Google requires the usage of an API key in order to use its Google Maps features ( read about it here ). So I might need to add an API key input box to the settings page be able to enter the Google API key.

    I am using Gravity Forms Geolocation Add-on – Version 2.0-beta-8 and Geo My WP – Version 2.6.5. My license for the Geolocation add-on has expired, but this should not effect the functionality correct?

    Correct. The plugin will be fully functional without a license key. However, you will need an active license key to receive future updates.

    I will let you know what I find regarding the API key.

    #53108

    solarteam
    Participant

    I’ve read through several other threads on this topic and I assume the issue has to do with the API key. I’ve created a browser API key and inserted into the setting page on the plugin, but the geolocation and auto complete functions on my website still are not functioning. Is there any thing else I can try to make this work?

    Thanks,

    #53111

    Eyal Fitoussi
    Keymaster

    Hello Solarteam,

    Checkout this reply from yesterday. After creating the API key you also need to enable some of the Google Maps services. This seems to solve the issue to other users.

    Let me know if that helps.

    #53116

    solarteam
    Participant

    Hi Eyal,

    Unfortunately this does not seem to be working. I’ve enabled all of the APIs and still receive the REQUEST_DENIED error. Again, my gravity form geolocation license has expired and I cannot download the new version, could this be the problem?

    #53121

    Eyal Fitoussi
    Keymaster

    Well, the latest version of the add-on has the text input field for the API key. If you can’t update the plugin than where exactly did you place the API key that you created?

    #53165

    solarteam
    Participant

    In the Geo my WP setting page under “Google Maps API V3 Key”. I assume this is the problem then?

    Is there a way that I wont have to pay for a new license, but still have this functionality? It doesn’t seem fair that I would have to pay again for a function that I originally had, but no longer do.

    Thanks again for the help

    #53227

    solarteam
    Participant

    Any update here? Will I just have to renew my license?

    #53255

    Eyal Fitoussi
    Keymaster

    Using the API key via GEO my WP should work, I believe.

    You need to check if the API call is being registered at all in your site and if the API key passes as well. You can look for the API call via the browser console.

    #53280

    solarteam
    Participant

    It looks like the API key is being called, but is coming back invalid. Any advice here? I attached the screen shot

    Attachments:
    You must be logged in to view attached files.
    #53283

    solarteam
    Participant

    I also tried this using Safari and the error message said there was no API key. Screen shot attached

    Attachments:
    You must be logged in to view attached files.
    #53291

    Eyal Fitoussi
    Keymaster

    It seems that the API key is not being called at all ( and I am not sure why ).

    Something you can try is disabling the API call made by GEO my WP using:

    then to register it via Gravity Forms Geolocation add-on. However, since you don’t have the API text input box, you will need to add it manually. In the latest version of the plugin there is the filter:

    that can be used for that. You need to check if your version has this filter and use it to add your API key. Otherwise, you will need to add the API directly to the core file. The filter, if exists, will be in the file gravityforms-geolocation/gravityforms-geolocation.php.

    I hope that helps.

    #53293

    solarteam
    Participant

    I simply don’t have the time or capacity to sit and try to figure that out. I have no idea where to find these filters or add anything to the core file, don’t know what either of those are.

    If I renew my license will the geocoding function work by adding the API key to the new field?

    #53340

    solarteam
    Participant

    Any word here? I’d really like to get this problem solved. Should I just renew my license and update the plugin?

    #53351

    Eyal Fitoussi
    Keymaster

    HI,
    I can’t say for sure if updating the plugin will work.

    When GEP my WP installed, its API call override the call made by Gravity Forms Geolocation add-on. So entering an API key in the input box of Gravity Forms Geolocation won’t change anything. However, for some reason, the API call made by GEO my WP does not work properly on your site. As you can, the error indicates that no API key was entered even tough you entered an API key in GEO my WP settings page.

    What you could do is disable the API call made by GEO my WP. You can do so by simply adding the line of code

    to the functions.php file of your theme/child theme.

    Then, if you update Gravity Forms Geolocation add-on and enter the API key it might work.

    I really hope that helps.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.