Forum: Geo Members Directory

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Members Directory premium extension please open a new premium support ticket.

[Resolved]Map of all users not displaying.

Home Forums Geo Members Directory Map of all users not displaying.

This topic contains 3 replies, has 2 voices, and was last updated by  JamesPickard 3 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #52497

    JamesPickard
    Participant

    Hi,

    I’m creating a new site (offline at the moment – Xammpp).

    I have installed Buddypress and the GEO my WP plugins with the add ons members locator and post type locator activated.
    I want to display the map of all my users, I have followed the instructions from a previous issue posted on this forum :

    What shortcode should I use, how can I display a simple map of all members on a page?
    1.Navigate to Dashboard -> GEO my WP -> Forms.
    2.Create a new Members Locator form ( the button at the top of the page ).
    3.In the form editor under the “Page Load Results” tab do the following: a.check the “Enable Page Load features” checkbox.
    b.uncheck the “Display list of results” checkbox.
    c.Set “Display map” radio button to “using shortcode”.
    d.Set the other settings of the tab as you wish.

    4.Navigate to the “Search Form” tab and set the “Search Form Template” dropdown to “disable search form”.
    5.In the page where you want to display the map add the shortcodes:
    [gmw map=”form ID”]
    [gmw form=”form ID”] .

    I have the shortcode [gmw map=”2″ name=”form_id_2″] on the page I want the map to display but nothing displays on that page. (page is completely empty).

    I only have 2 users at the moment, just to test functionality.

    I can get the GWM current location to work displaying my current location but that’s it.

    Is there anything else I can try? Do I need the global maps add on?

    Thank you for your help

    James

    #52518

    Eyal Fitoussi
    Keymaster

    Hello James,

    I have the shortcode [gmw map=”2″ name=”form_id_2″] on the page I want the map to display but nothing displays on that page. (page is completely empty).

    As described in the steps above you should place both shortcodes in the page:

    Also, please type in the shortcodes to your page editor instead of copy pasting it as sometimes it won’t work.

    Let me know if that helps.

    #52564

    JamesPickard
    Participant

    Hi Eyal Fitoussi,

    Thank you for the info. I typed the shortcode as you described, now the page just shows a line and a loading icon on the page – see attached screenshot of the line.

    I have tried changing map sizes but it just reduces the size of the line and loading icon.

    Thanks

    James

    Attachments:
    You must be logged in to view attached files.
    #52567

    JamesPickard
    Participant

    Hi again,

    I unchecked the border around map box and the map started working.
    I have just turned the border back on and it is working fine, not sure why that happened.

    Thank you for your help.

    James

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.