Forum: Bug Reports

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support and general questions related to GEO my WP plugin and its core add-ons please use the support forum.

[Resolved]Overlays not Displaying beacuse of https and /wp-admin/admin-ajax.php Call

Home Forums Bug Reports Overlays not Displaying beacuse of https and /wp-admin/admin-ajax.php Call

This topic contains 4 replies, has 2 voices, and was last updated by  Scott Reimels 4 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #28797

    Scott Reimels
    Participant

    I am having an issue with the Overlays of my map points displaying.
    I have pegged the issue to be after switching to ssl => https the over lay will not display because its content is being blocked via a non-https call, IE: http://site.com/wp-admin/admin-ajax.php.

    I have found that this reference is coming from the DB in:
    wp_options => opion_name => gmw_forms
    I figured if i change the url to https my overlay content will not be blocked BUT When ever I change http://site.com/wp-admin/admin-ajax.php => https://site.com/wp-admin/admin-ajax.php.
    My Forms disappear.
    I have no idea why this is happening.

    On the site currently i have the URL in the DB without the https so you can see how the overlays are not displaying
    Any help would be great…

    #28801

    Scott Reimels
    Participant

    Hi Eyal,
    Thanks for the quick reply!
    I am on WPEngine and i have the SSL settings set to be used in the wp-admin and wp-content folders.

    I also have made the change you suggested, but still not displaying.
    I am almost certain this ajax URL is coming from the DB…

    Im not sure if this has to do with anything, BUT I have imported the forms data from my dev site to production.

    See prvt content.

    Private Content Hidden
    #28800

    Eyal Fitoussi
    Keymaster

    It is indeed being saved in database but the initial source is from the line that you have just modified.

    Please go to the form editor in admin and re-save the form that you are using. Then try again.

    #28799

    Scott Reimels
    Participant

    Hi Eyal,
    YOU THE MAN!
    got it..I guess that need to regenerate the entry with the https in there..awesome!

    There was another file where i had to manually go into and change an http => https..BUT i cant remember where the heck it was.

    Might want to put something some where about https issues..maybe in the read me..OR an option in the setting woudl be great!

    thanks for your hard work your plugin rules…
    this is the 3rd site i have it on and each site is a big profit generator for me so thanks again!

    Once this one launches i would love to display it in your gallery of examples.

    thanks,
    Scott

    #28798

    Eyal Fitoussi
    Keymaster

    Thank you Scott for the kind words and thank you for the kind purchases. your support is greatly appreciated.

    I am seriously happy to know that you find my work useful and that your projects are successful; It is a great feeling. And you are welcome to submit any of your project at any time using this form.

    A fix for the issue above already implemented in the next version of the plugin and hopefully will be released soon. So I don’t think there is a need to mention it in the realm file.

    Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.