Forum: Bug Reports

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support and general questions related to GEO my WP plugin and its core add-ons please use the support forum.

[Resolved]Pagination doesn't work

Home Forums Bug Reports Pagination doesn't work

This topic contains 6 replies, has 2 voices, and was last updated by  Eyal Fitoussi 4 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #36414

    mattmatt
    Participant

    Hello again :),

    The pagination doesn’t seem to work for me. It didn’t work with the previous version and also not with the new beta.

    – Already tried to deactivate all plugins
    – Already tried to change to the default theme
    – Already tried to use the default search form and result page
    – I’m using permalinks structure “/blog/%postname%/”

    I have two forms on two different pages. In the pages where the search form and the results are displayed, there’s only this shortcode “[gmw form=”results”]”.

    The search page look something like this:

    http://mypage.com/search/page/2/?gmw_post=dog&gmw_distance=24&gmw_address%5B0%5D=Hauptstrasse%208%2C%201100%20Wien%2C%20Oesterreich&gmw_units=metric&gmw_form=1&gmw_per_page=2&gmw_px=pt&action=gmw_post&noredirect

    In difference to the GMW-Demo, where the pagination is a GET variable “&paged=2”

     

    The first page always displays results, but the other ones just show the shortcode [gmw form=”results”]. No search form, no results.

    Do you have any idea what can be wrong?

     

    Thank you

    #36451

    Eyal Fitoussi
    Keymaster

    Hi,
    Looking at the link you provided the results display fine. Did you get that fixed?

    Regardless, I don’t completely understand how your setup works. It seems like you have done some custom modifications ( which looks awesome BTW ) but I don’t see the pagination links. Seems like your setup has an infinite scroll rather than pagination?

    #36479

    mattmatt
    Participant

    Oh, this link was just an example link (mypage.com). Didn’t know that there is an existing site 😉

    So I use your default plugin, not the one used on that page 😀

    #36584

    Eyal Fitoussi
    Keymaster

    Oh man, I should have known… I blame it on the late hours..:)

    Is the search form placed in the home page?

    #36587

    mattmatt
    Participant

    No it’s two forms on two different (not home) pages.

    #36899

    mattmatt
    Participant

    Oh man, searched for hours and now got it.
    Wasn’t a problem with your plugin. It was just a problem with “Plugin Organizer” that deactivated the plugin for page 2

    Fixed. Thank you.

    #37147

    Eyal Fitoussi
    Keymaster

    You are welcome, I am glad you got it fixed.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Pagination doesn't work’ is closed to new replies.