Forum: Gravity Geolocation

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Gravity Geolocation premium extension please open a new premium support ticket.

[Resolved]Run the Geocoder only if required, not on every page

Home Forums Gravity Geolocation Run the Geocoder only if required, not on every page

This topic contains 10 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #52029

    Neha Arora
    Participant

    Hi Eyal,

    I am using GeoMyWP to get the user’s location when they’re filling a Gravity Form. This is built over BuddyPress plugin. I am facing the following two problems:
    1. If the browser’s Geolocation feature is off, it keeps throwing popups repeatedly with the “User denied the request for Geolocation” message on every page of the website.
    2. If the browsesr’s Geolocation is on, I’m getting “OVER_QUERY_LIMIT” popups, again repeatedly on every page.

    I understand that both these issues are related to the Google Maps API with no direct resolution.

    But my question is that, can I selectively invoke the Geocoder, like in my case – only when the form is opened and a “Get Current Location” button is clicked? Currently, it seems that the Geocoder is invoked at every page, hence the popups.

    Please note the Settings I’m using for this:
    – Client-side ( Javascript ) geocoding is enabled
    – Auto locator is disabled
    – Among the GeoMyWP add-ons, only Gravity Forms Geolocation 2.0-beta-15 is active. All other add-ons are deactivated.

    #52034

    Neha Arora
    Participant

    Hi, I was able to figure out the cause of this issue. It was related to the Popup Maker plugin that I was using to open the forms as popup. So, the OVER_QUERY_LIMIT error was resolved.

    But my question still remains (if that makes any sense). Can that be the reason that I keep getting Geolocation Denied message over and over?

    #52120

    Eyal Fitoussi
    Keymaster

    Helo Neha and apologize for the delayed reply.

    If you disable the auto-locator in the Gravity Form, would you still see the alert message?

    #52133

    Neha Arora
    Participant

    Yes, even if the Auto-Locate is off, I get the alert message when the form gets loaded, before I click on the Get Current Location button.

    #52207

    Eyal Fitoussi
    Keymaster

    Can you please update to Gravity Forms Geolocation 2.0 beta 18 ( can be downloaded from your account page ) as well as provide a link to the live form?

    Thanks,

    #52269

    Neha Arora
    Participant

    Hi Eyal, I have updated to 2.0 Beta 18, and here are the form details:

    (I still get the pop up when I load the page)

    Private Content Hidden
    #52287

    Eyal Fitoussi
    Keymaster
    This reply has been marked as private.
    #52492

    Eyal Fitoussi
    Keymaster

    This topic marked “Resolved” due to inactivity. If you wish to reply to this topic please change its status to “Not resolved”  before replying.

    #52493

    Neha Arora
    Participant
    Private Content Hidden
    #52583

    Eyal Fitoussi
    Keymaster

    Thanks.
    I don’t see any issue with the plugin. The auto-locator is not generating on every page but only on pages with Gravity Form when the “Page Locator” is enabled in the Geocoder field. Once I disabled the “page Locator” the auto-locator is not showing anymore.

    Now, Google recently has disabled the geolocation feature in its Chrome browser for sites without SSL certificate installed. That means that if you have the page locator enabled for a form and a user views the form on Chrome browser, he will automatically see the “User denied….” message without having the option to give permission for geolocation or not.

    I hope that makes sense.

    #52700

    Eyal Fitoussi
    Keymaster

    Marking this topic resolved. If you are having any other issues regarding the above please change the topic status to “not resolved” before replying.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.