GEO my WP Support

Use this forum for technical support and general questions related to GEO my WP plugin and its core add-ons only. For technical support and general questions related to any of the premium extensions please open a new premium support ticket.

[Resolved]Search form's widget doesn't work after upgrade

Home Forums Support Search form's widget doesn't work after upgrade

This topic contains 24 replies, has 3 voices, and was last updated by  Eyal Fitoussi 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #57531

    magod
    Participant

    Hello Eyal,

    After upgrade to version 3.0 beta 7 Search form’s widget doesn’t work anymore. We can only see the title but not the research elements.
    Other widgets work perfectly (single and current location)
    Do you have an idea of what’s the problem?

    Thank you so much for helping.

    Magod

    Attachments:
    You must be logged in to view attached files.
    #57533

    Eyal Fitoussi
    Keymaster

    Hello Magod,

    I am not sure, but at this point, you should upgrade to the official release of v3.0 rather than using the beta.

    After you do so, delete the widget and recreate it to see if it fixes the issue. It is doesn’t, let me know and I will look into this again.

    #57565

    magod
    Participant

    Hello Eyal,

    Can you give me the link to version 3.
    I tested version 3.0-beta2 and it doesn’t work any better.
    Thank you so much for your help.
    Absolutely great plugin!

    Regards

    Magod

    #57566

    magod
    Participant

    Hello Eyal,
    I just realized that it’s not the update that’s a problem but the form that’s incorrectly configured.
    I’ll try to find out what’s wrong.
    I’m really sorry

    Regards

    Magod

    #57567

    Eyal Fitoussi
    Keymaster

    Not a problem Magod.

    And version 3.0 was officially released a couple of months ago. You should be able to update it from your dashboard or download it from WordPress.org.

    #57576

    magod
    Participant

    Hy Eyal,

    https://messagespourlaterre.com/

    1 – When I search by location, I do not have the only members in the requested radius (e.g. 5km) but all registered members.
    Probably, the parameters are not good? Capture 1

    2 – On the file -capture 2- I have 2 times the same text.
    How can I delete the second ? Capture 2

    Thanks a lot for helping.

    Magod

    Attachments:
    You must be logged in to view attached files.
    #57579

    Eyal Fitoussi
    Keymaster

    Hello Magod,

    1. If you are trying to display the search results using BuddyPress directory page, then that is not how the plugin works.

    GEO my WP uses its own search form and search results template files. You need to use GEO my WP shortcodes to display the search form and search results.

    2. You need to either hide this using CSS, which should be the easier approach. Or create custom search results template file and remove the function that generates the text from the file.

    #57585

    magod
    Participant

    Hello Eyal,
    1. I misunderstood myself. It works perfect with the good settings:
    “The results page displays the search results in the selected page when using the “GMW Search Form” widget, or when you wish to have the search form in one page and the results showing in a different page. To use this feature, select the results page from the dropdown menu and paste the shortcode [gmw form=”results”] into the content area of that page. Otherwise, select “Same Page” to display both the search form and search results in the same page.”
    2. This does not work because if I remove the bottom line, I also delete the top line. CSS: div.gmw-results-wrapper.yellow .results-count-wrapper
    Isn’t it?

    #57586

    Eyal Fitoussi
    Keymaster

    Magod,

    1. Great. I see it is working now.

    2. I don’t see the text showing twice anymore. Anyway, It should be the case only with the default results template file, I believe. And in this case, the text should be within another element with a class something like ‘pag-bottom’. Which you can use to only hide the bottom text.

    #57599

    magod
    Participant

    Hy Eyal,
    1- work fine !!

    2- I couldn’t find class something like ‘pag-bottom’.
    To delete the list of members under the map using the shortcode [gmw form=”4″], I used this css:
    div.gmw-results-wrapper.yellow ul.members-list-wrapper li {
    display: none;
    }
    div.gmw-results-wrapper.yellow .pagination-per-page-wrapper {
    display: none;
    }

    Maybe there is a shortcode to display only the map? I tried with[gmw map=”4″] but it doesn’t work.

    Regards.

    Magod

    #57602

    magod
    Participant

    Other question:
    I don’t see all the members registered yet I know the locations have been made
    Can you help?

    Thanks a lot

    Magod

    #57606

    magod
    Participant

    SOS: nothing works anymore
    error message
    Google Maps JavaScript API error: InvalidKeyMapError
    But my key is the right one

    Can you help, please?

    Regards

    Magod

    #57622

    Eyal Fitoussi
    Keymaster

    Have you added a billing account to your Google Maps API account?

    See this post for more details.

    #57628

    magod
    Participant

    Yes, I do.

    #57650

    Eyal Fitoussi
    Keymaster

    IN the attached image you can see the error message on your site. The errors indicate that Google Maps is registered multiple times on your site. I can also see that it is registered twice with different Google Maps API key.

    If you have installed an additional mapping plugin, you need to either disable it or enter the same Google Maps API key in both GEO my WP and the other mapping plugin.

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 25 total)

You must be logged in to reply to this topic.