Forum: Gravity Geolocation

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Gravity Geolocation premium extension please open a new premium support ticket.

[Resolved]SSL broke Geolocation

Home Forums Gravity Geolocation SSL broke Geolocation

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #52792

    Alistair Mountain
    Participant

    I added an SSL certificate to fix the ‘user denied geolocation’ and now the map no longer shows on my page.

    I have tried deactivating the plugin and reinstalling it but to no luck.

    This is now across all browsers and is no longer a problem just with Chrome.

    Private Content Hidden
    Attachments:
    You must be logged in to view attached files.
    #52796

    Eyal Fitoussi
    Keymaster

    HI,
    Yes, there should be information and settings in the map field.

    Have you tried deleting the map field and creating a new one?

    Also, can you look in the browser console for JavaScript errors?

    Thanks,

    #52812

    Alistair Mountain
    Participant

    I’ve managed to get the location reappearing after deleting and rebuilding – the layout of the Gravity form is slightly different now but so far this is working fine. The only problem now is the google suggestions. In the form field ‘I swigged at’ you should be able to search for a location (this is auto-populated with your current location which is fine but I allowed the user to search here too) I have had problems with this in the past but I can’t remember how I fixed it. I’ve unchecked and rechecked the box but to no avail.
    Any suggestions?

    Private Content Hidden
    #52819

    Alistair Mountain
    Participant

    After a bit of tinkering I’ve managed to fix it.
    Adding https to the site to get this feature working again has been a real pain and has made the site really slow on mobile.

    #52832

    Eyal Fitoussi
    Keymaster

    Hello Alistair,

    I am glad you got everything working now.

    Regarding the Auto-locator feature; HTTPS is now required only for Chrome browser. That is since Google Disabled the geolocation feature for non secured pages. Many users have been complaining regarding this new restriction. Unfortunately, there is nothing that can be done about that but installing SSL certificate.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.