Forum: Feature Requests

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Feature Requests premium extension please open a new premium support ticket.

[Not resolved]Starting address does not work

Home Forums Feature Requests Starting address does not work

This topic contains 15 replies, has 2 voices, and was last updated by  gueffo 3 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #53639

    gueffo
    Participant

    Thank you first of all for the great plugin! It basically works wonderfully. Unfortunately I’m a bit desperate because of the following “simple” problem: I’ve established a “starting address”, but the results page returns no result. There are posts that should be delivered. I’ve written the “starting address” in different ways. And of course, I’ve also tried to use the “Filter by city, state, …”. But there is no result. What can be wrong?

    #53648

    Eyal Fitoussi
    Keymaster

    Hello Gueffo and you are welcome.

    Do the posts show in the results if you submit the search form?

    #53668

    gueffo
    Participant

    Hi Eyal! Thanks for the fast reaction.
    There are results when I retrieve the page with the search form and no “Starting Address” is set in my backend in the search form settings.
    There are also results when I use any selection criterion – e.g. entering a particular place, using a taxonomy, selecting a kilometer number.
    As “Starting Address” I registered at the moment “Bochum”. I tried it also with “Bochum, Deutschland” and “Bochum, Germany”.
    Below the Website URL if you may have a look to the problem in my “construction zone”.
    Thanks a lot!

    Private Content Hidden
    #53731

    gueffo
    Participant

    Hello Eyal!
    Sorry for urging a little. 🙂 Do you have any hint for me how i could solve my problem with the Starting address.

    Thanks
    Günter

    #53770

    Eyal Fitoussi
    Keymaster

    Hi Gunter,
    Which shortcodes did you place on that page?

    #53778

    gueffo
    Participant

    Hi Eyal,
    it’s just [gmw form=”1″]

    #53847

    gueffo
    Participant

    Hi Eyal!

    Please, could you help me in the issue „Starting Address“.
    I checked the problem with another domain. There I installed new WordPress, new gmw, no other plugins, used the WP-Default-Theme. But the „Starting Address“ does not work. Am I the only one with this problem? Do you have any idea how to handle this issue?

    Thanks
    Günter

    #54053

    gueffo
    Participant

    Hi Eyal!

    Please, give me any reaction! Is there a chance to solve my problem with the starting address?

    Thanks
    Günter

    #54074

    Eyal Fitoussi
    Keymaster

    Hello Günter,
    I apologize for missing out your replies. I have been having serious issue with the support forum and the notification system. However, a new site with new ticketing system is under development and will be live soon.

    If you can provide me with admin access to the site I will take a look at it and see if I can find the issue.

    #54082

    gueffo
    Participant
    This reply has been marked as private.
    #54083

    gueffo
    Participant
    This reply has been marked as private.
    #54095

    Eyal Fitoussi
    Keymaster

    Thank you.

    The first issue was that you checked the “Posts” checkbox in the Post Types setting of the Page Load results tab, when it suppose to be “DJs” Post types. However, it is still not working because your site get the “OVER_QUERY_LIMIT” error which returns by Google API. That means that the plugin cannot geocode the address “Bochum Germany” and that is why there are no results.

    To confirm that, you can go to GEO my WP Settings page and uncheck the “Client-Side geocoder” checkbox. Then try to submit ( not page load ) the search form, which usually return results, but you will get an error. Thats is because many times the Client-side geocoder will overcome the OVER_QUERY_LIMIT error. However, the client-side geocoder takes place only on form submission and not on page load results.

    OVER_QUERY_LIMIT error returns when you use up the 2500 geocode queries per 24 hours. 2500 queries should be enough for an average traffic website. However, the 2500 queries are per 24 hours per IP address. And many times on shared hosting a few sites which share the same IP address will all use the Google maps API. That means that all the sites are sharing the 2500 queries. That is most likely what happens in your case. I assume that your site hosted on a shared server and other sites that are on the same server are using-up the Google Maps queries.

    There is not much that can be done about that. If you want to completely overcome the OVER_QUERY_LIMIT error you should probably call the host provider and see if it is possible to change the IP address of your site. Which hopefully will help. Or you could try a dedicated host.

    Until then, you can simply remove the “Starting address” and display all results on page load.

    I hope that helps.

    #54138

    gueffo
    Participant

    Hello Eyal!

    Thank you for your notes. But: Why is the Query-Limit only a problem for the initial load of a form with a Starting Address? Why is no problem, when i submit the form? I’m sharing the IP-Address all the time, even if I submit the form.

    However, especially I‘m confused at the moment due to the following phenomenon: If I’m using the Starting Address „Bochum“ – the place that I‘ve used recently most frequently – then the page load with correct results (just for Bochum). But if I enter some other place, then it does not work. Is there any memory which memorizes a place commonly used?
    (Excuse my perhaps „stupid“ questions.)
    Thanks
    Günter

    #54153

    gueffo
    Participant

    Hello Eyal!
    I’ve found the place where „Bochum“ is stored. It is in the table „wp_options“. The are files named like „_transient_gmw_geocoded …“ and „_transient_timeout_gmw_geocoded …“. I’m sure you know more about this issue than I do. Could it be a way there?

    #54186

    Eyal Fitoussi
    Keymaster

    Hello Gunter,

    Why is the Query-Limit only a problem for the initial load of a form with a Starting Address? Why is no problem, when i submit the form? I’m sharing the IP-Address all the time, even if I submit the form.

    That’s because on form submission the client-side geocoder ( geocoder via JavaScript ) is being triggered while on the page load results the geocoder is made via HTTP call. And the client-side geocoder is known to overcome the OVER_QUERY_LIMIT issue. AS mentioned above, you can confirm that by unchecking the Client-side checkbox in GEO my WP settings and then test the search again. You will then see an error message.

    However, especially I‘m confused at the moment due to the following phenomenon: If I’m using the Starting Address „Bochum“ – the place that I‘ve used recently most frequently – then the page load with correct results (just for Bochum). But if I enter some other place, then it does not work. Is there any memory which memorizes a place commonly used?

    Geocoded address are being saved in transient ( as you mentioned in the above reply ) to reduce the geocoder usage. So, if at some point the address “Bochum” was properly geocoded ( when there was no OVER_QUERY_LIMIT error ) then the geocoded data will be saved in transient and the plugin will use this information on page load instead of trying to geocoded the address again. With other address, perhaps, the geocoder keeps failing because of the OVER_QUERY_LIMIT error.

    I hope that makes sense.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.