Forum: Xprofile Fields

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Xprofile Fields premium extension please open a new premium support ticket.

[Resolved]Turning off auto-fill

Home Forums Xprofile Fields Turning off auto-fill

This topic contains 15 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #51470

    Carrie Bishop
    Participant

    Hi,
    I am using xprofile fields, and I have a separate field for Address / City / State / Zip. However, when I put the Address portion in (Such as 1210 Hull Road), the rest of the data is getting autofilled in that same field (city, state, zip). I don’t want this to happen – I want to be able to display the address on a separate line from city/state/zip in the directory.

    How do I turn off auto-fill? I’ve tried in multiple browsers and it seems to be the plugin that is doing it, not the browser. I’ve unchecked Autolocator and Google auto fill in the GeoMy Wp settings.

    Thanks!

    #51484

    Eyal Fitoussi
    Keymaster

    Hello Carrie and thank you for the purchase.

    However, when I put the Address portion in (Such as 1210 Hull Road), the rest of the data is getting autofilled in that same field (city, state, zip)

    1) Does it dynamically happen while typing the address or only after form submission?

    2) Does it happen during registration, in the member “Edit Profile” page or both?

    3) Which version of the plugin are you using?

    Thanks,

    #51486

    Carrie Bishop
    Participant

    Hi!

    1) it happens both dynamically while typing the address,and then I delete the city/state/zip and save,and it is added back after form submission.

    2) It also happens during registration AND during Edit Profile.

    3) Using version 4.4.2

    #51491

    Eyal Fitoussi
    Keymaster

    Thank you.

    Can I have a look at the live “Edit Profile” page?

    Regarding the version, I mean the version of GEO my WP Xprofile Fields add-on that you are using.

    #51623

    Carrie Bishop
    Participant

    Hi Eyal,
    I am using version 1.3.1 of Xprofile fields.

    Do you want a log in, or a screenshot of the Edit Profile page?

    Carrie

    #51657

    Carrie Bishop
    Participant

    Hi – I’ve got a screenshot of what happens when I edit the address field in the Extended Profile editing area. Attached below.

    Attachments:
    You must be logged in to view attached files.
    #51673

    Carrie Bishop
    Participant

    Another update: it does NOT happen when I create an account from the registration screen: http://yarngroup.wpengine.com/register

    #51710

    Eyal Fitoussi
    Keymaster

    Thank you for the screenshot Carrie.

    Looks like you setup the Xprofile Fields to work as a Single Address field instead of multiple address fields. That is why this is happening to you.

    Please navigate to the Xprofile Fields tab of GEO my WP settings page and set the radio button to “Multiple address fields”. Then choose the profile field for each of the address fields.

    Let me know if that helps.

    #51765

    Carrie Bishop
    Participant

    Hi Eyal, it was already set up like that – I double checked.

    Thanks,
    Carrie

    #51769

    Eyal Fitoussi
    Keymaster

    Hi Carrie,

    In the screenshot I see the Google Address Autocomplete in being used on the address field. The Autocomplete feature should only be enabled when the single address field is selected. That’s why I assumed that you have the Xprofile Fields set to single address field. So looks like something is not working properly.

    Regardless, I have just released version 1.4 of the add-on. Please update your plugin and see if it takes care of the issue.

    let me know if it helps.

    Thanks,

    #51786

    Carrie Bishop
    Participant

    Hi Eyal, the update didn’t resolve the issue. It is still autofilling. See screenshot. thanks!

    Attachments:
    You must be logged in to view attached files.
    #51794

    Eyal Fitoussi
    Keymaster

    Can you please confirm that you have version 1.4 installed?

    A new “GEO my WP Location Status” meta box was added to the admin’s Extended Profile page in version 1.4. And I don’t see this meta box in the screen shot above.

    Sometimes, a glitch in GEO my WP updater system will not install the new version of the add-on that was just released but the same version that you have active on the site ( means that the updater simply reinstalled version 1.3.1 on your site instead of version 1.4 ). Please navigate to the plugins page and see if the “New version available” message is still showing for the add-on. If so, please run the update again.

    #51808

    Carrie Bishop
    Participant

    Hi Eyal, I ran the updater again and updated the plugin.

    The auto fill doesn’t happen when I type in the address initially (see first screenshot) but when I click “Update Profile”, it adds the rest of the address auto fill back in (see second screenshot.)

    Thanks,
    Carrie

    Attachments:
    You must be logged in to view attached files.
    #51811

    Eyal Fitoussi
    Keymaster
    This reply has been marked as private.
    #51965

    Eyal Fitoussi
    Keymaster

    Hello Carrie,
    Do you still need help with the above?

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.