Forum: Geo Job Manager

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Job Manager premium extension please open a new premium support ticket.

[Resolved]User denied the request for Geolocation.

Home Forums Geo Job Manager User denied the request for Geolocation.

This topic contains 6 replies, has 4 voices, and was last updated by  robongda 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #51895

    Patrik
    Participant

    Not sure whether this is a feature or a bug…

    When “Page load auto-locator” is disabled and the locator button is enabled I get “User denied the request for Geolocation.”

    My assumption was that by disabling “Page load auto-locator” the user would be able to click the “locator button” and have the location field populated. Is the “locator button” in any way dependent on the “Page load auto-locator” option?

    The issue can be replicated here:
    http://talentedteacherjobs.co.uk/

    #51904

    Eyal Fitoussi
    Keymaster

    Hi Patrick,
    This message means that the user did not give a permission for the browser to retrieve his current location and he most likely check the checkbox that saves his choice for the day. You need to clear your location settings in the browser and it will work again.

    it works fine for me when I tested it.

    Let me know if that helps.

    #51926

    Patrik
    Participant

    Hello Eyal,

    thank you for your reply. I have tried that, I have cleared everything until “the beginning of time”. I have even created new profile in Chrome and also tried incognito and browse as guest.

    The issue is only with Chrome on Mac. Safari works fine. Chrome on Windows works fine too.

    I have even checked Chrome settings via: chrome://settings/contentExceptions#location. All looks good there.

    #52068

    Eyal Fitoussi
    Keymaster

    Hello Patrick,
    Unfortunately, last month Google disabled the geolocation features in chrome for unsecured pages. That means that in order to use the auto-locator feature in Chrome you will need to install SSL for your site.

    Only last week I have found out about it. You can read more about it here.

    #52097

    Patrik
    Participant

    Aha! Thank you for the confirmation Eyal.

    Best Regards.

    #53547

    harish
    Participant

    Hi Eyal, I am facing same issues from my website and i had install SSL, i am using vps server rout with cloudflare server. i am facing same error “User denied the request for Geolocation” now i am using JobCareer Theme Kindly assist.

    Note : i am followed your all istructions which is erlier provided by you.

    Regards
    Harish

    #59593

    robongda
    Participant

    hi :))

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.