Forum: Xprofile Fields

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Xprofile Fields premium extension please open a new premium support ticket.

[Resolved]Values not being stored correctly

Home Forums Xprofile Fields Values not being stored correctly

This topic contains 3 replies, has 2 voices, and was last updated by  Robin 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #54000

    Robin
    Participant

    Hi

    I seem to have an issue here. I have xprofile fields setup as follows:
    ‘City’ mapped to an input field of ‘City/District/Town’
    ‘State’ mapped to an input field of ‘County/State’
    ‘Country’ mapped to an input field of ‘Country’

    I find the values are being saved incorrectly. For example, I enter the address in Buddypress as being:
    ‘City/District/Town’ = Hastings
    ‘County/State’ = East Sussex
    ‘Country’ = England

    When I save the values have been changed to:
    ‘City/District/Town’ = Hastings
    ‘County/State’ = England
    ‘Country’ = GB

    Any ideas?! This is really annoying as the address is not being stored as accurately as it should be and it just looks wrong on my member profiles.

    Many thanks

    #54016

    Robin
    Participant

    Hi

    Jus to say after some more testing I don’t think this is a bug.
    I am guessing it is google updating the address?

    I googled and there are two Hastings in the USA. When I enter:
    ‘City/District/Town’ = Hastings
    ‘County/State’ = Nebraska
    ‘Country’ = USA
    It is saved correctly and the map updated.

    When I enter:
    ‘City/District/Town’ = Hastings
    ‘County/State’ = Michigan
    ‘Country’ = USA
    It is saved correctly and the map updated.

    I guess it is because google does not need the county/state for Hastings in the England as there must only be one, so it replaces the value of East Sussex with England.

    This is annoying as users can’t now search their county for members, but I guess it can’t be helped/ changed?

    #54029

    Eyal Fitoussi
    Keymaster

    Hello Robin,
    I apologize for missing out your initial post.

    You are correct, when member updates his location Google geocodes the address and return the “proper” address fields which sometimes might be slightly different than what you entered. However, assuming that you are referring to GEO my WP search forms, members should still be able to search for other members based on a county, even if the county name does not exist in the address of a member. The search is done based on coordinates and not the actually address field. So, if one searches for members based on the address “Hastings, East Sussex”, for example, he should see your member profile in the results even if the value “East Sussex” does not exist in the address of your member.

    Does that makes sense?

    #54140

    Robin
    Participant

    Resolving

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.