Forum Replies Created

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • in reply to: small core hack #54682

    dlx
    Participant

    Thanks for the hint! I was able to change the text because Loco Translate did not work in this case.

    But there is a problem when using this on a community where members enter their private location. To remain their privacy I added the code below so only country + city is being displayed in their profile. But when updating their location the whole address is being shown in the activity stream. There definitely should be an option to hide the address und don´t link to Google Maps. I changed this in the code but a solution that remains after updating the plugin would be perfectly!

    Best regards,
    Jan

    function gmw_modify_displayed_member_address( $address, $info, $gmw ) {

    $address = ”;

    if ( ! empty( $info->city ) ) {
    $address .= $info->city.’ ‘;
    }

    if ( ! empty( $info->country ) ) {
    $address .= $info->country. ‘ ‘;
    }

    return stripslashes( $address );
    }
    add_filter( “gmw_location_address”, ‘gmw_modify_displayed_member_address’, 10, 3 );

    in reply to: Geolocate existing users #54571

    dlx
    Participant

    Hi! A solution for this would be great – I have the same problem…

    Best regards,
    Jan

    in reply to: Bug when using Formidable + Kleo Geo Location #54195

    dlx
    Participant

    Hi Eyal,

    ok, I found the API key in the Formidable Settings page and entered it. The error is gone but the language & country settings of the Formidable Add-On are overwriting the Kleo settings.

    I looked in the code of formidable-geolocation.php:
    In the lines 154 and 155 the language & country settings are set.

    ‘region’ => ‘us’,
    ‘language’ => ‘en’,

    I edited them and now the Kleo search works again (displays correct language). I tested this several times so I can say the hard coded language & country settings of the Formidable Add-On overwrite the Kleo settings.

    I think it would be perfect if you could add settings for language & country in Formidable as well.

    Best regards,
    Jan

    in reply to: Default Map-Settings are overwritten #54115

    dlx
    Participant

    Hello Eyal,

    do you have any idea for a solution for this?

    Best regards,
    Jan

    in reply to: Post/page locations on Kleo users map #53620

    dlx
    Participant

    Hello Eyal,
    ok, good to hear it´s on your todo list. I really think this would be a great unique feature!

    Keep on the good work! I´m really happy I found Geo my WP!
    Jan

    in reply to: Hide address in BuddyPress profile #53534

    dlx
    Participant

    Wow, yes! Looks great! Thanks a lot!

    in reply to: Hide address in BuddyPress profile #53532

    dlx
    Participant

    No, the Single Location core add-on is not activated.
    Should I activated it to get more options?

    To be noticed: I´m not sure if the code I provided is correct. I´m not a PHP pro… 😉

    in reply to: How to translate : "you are here" on the map… #53503

    dlx
    Participant

    Works perfectly!
    Thanks a lot!

    in reply to: Hide address in BuddyPress profile #53496

    dlx
    Participant

    Hi Eyal!

    Found the filter in gmw-fl-component.php but don´t know how to add this to my functions.php.
    I tried the following code:

    Unfortunately this didn´t change anything.

    in reply to: How to translate : "you are here" on the map… #53485

    dlx
    Participant

    Could someone please post a solution for this?
    I´m having Geo my WP + Kleo geolocation installed and already tried to translate the text “You are here” of the blue marker on the map using “Locotranslate” plugin. But this didn´t work.

Viewing 10 posts - 1 through 10 (of 10 total)