Forum: Sweet Date Theme Integration

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Sweet Date Theme Integration premium extension please open a new premium support ticket.

[Resolved]Search not working correctly

Home Forums Sweet Date Theme Integration Search not working correctly

This topic contains 10 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #52419

    Petra
    Participant

    Hi,

    I am using SweetDate-Child theme, installed your plugin and activated Members Locator Add-on, Sweet Date Geolocation Add-on and also Xprofile Fields Add-on.

    I am facing following problems with the search in Member’s directory:
    ( I have created 5 members to test it out )

    1.The map is showing wrong numbers of the member in each city. All red marks are showing wrong amount of members ( should be 1 member in each city showing ), but the blue mark is showing correct number of the members. When I zoom the blue mark, it will change into the red ones and start showing again wrong amount members in each city.
    Please see images 1, 2 and 3.

    2. when I search members by gender and distance, I end up with message “Your search returned 2 members” ( which is the total number of men members ) and the search will show just 1 member under the map ( which is correct as only 1 of the 2 men are within the distance searched ).
    Please see image 4.

    Any idea how to resolve this?

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #52439

    Eyal Fitoussi
    Keymaster

    Hello Petra,

    1)

    The map is showing wrong numbers of the member in each city. All red marks are showing wrong amount of members ( should be 1 member in each city showing ), but the blue mark is showing correct number of the members.

    The numbers on the red markers do not represent a number of members. It represents the location of the member in the list of results. So, marker with the number 1 belongs to the first member in the list of results which also means in the nearest user to the address entered ( if entered at all ).

    2)

    when I search members by gender and distance, I end up with message “Your search returned 2 members” ( which is the total number of men members ) and the search will show just 1 member under the map ( which is correct as only 1 of the 2 men are within the distance searched ).

    I believe that another user reported a similar issue. I am going to look into that.

    #52447

    Petra
    Participant

    Hi Eyal,
    thanks a lot for such a quick reply! It’s really appreciated 🙂

    1) Of course the red marker represents the location of the member in the list of results…silly me. I have gallery view of my members and there is no reference number showing how far are the members in the list result so it is a little bit confusing. Is there any way we can show the corresponding number by the member’s profile in the search result? Once I’ll have more members, users will have difficulties to locate the correct member in the result list. ( hope you understand my explanation 🙂

    2) It would be amazing if you can sort this issue. I’m sure it will definitely help others as well 🙂

    Thanks

    #52553

    Eyal Fitoussi
    Keymaster

    You are welcome Petra,

    1) I assume that you are using a custom results template file? Because the template files included with GEO my WP should display the number of each member in the list of results.

    If you are indeed using a custom results template file you can display the member count using:

    Let me know if that helps.

    2) Sorry about the delay but I am still looking for a solution for that.

    #52560

    Petra
    Participant

    Hi,

    thanks for your reply.

    1) thanks for the code. Could you please guide me into which file shall I put this code?

    2) great…good luck with that 🙂

    #52581

    Eyal Fitoussi
    Keymaster

    Hi,

    thanks for the code. Could you please guide me into which file shall I put this code?

    I am not sure. With the custom results template files the members’ number should display in the results so I can only assume that you are using a custom results template file. Am I right? Otherwise, which results template are you using?

    #52683

    Petra
    Participant

    Hi Eyal,

    I have put your code into members-loop.php file as directed by Sweetdate team and although I tried to put your code into every single line, it didn’t do anything. Could you please double check on the code? Or could you kindly advise me where to put your code? I’ve used the code in this form
    <?php echo $members_template->member->member_count; ?> as again advised by Sweetdate team.
    Please find attached members-loop.php file.

    Thank you very much!

    #52684

    Petra
    Participant
    This reply has been marked as private.
    #52687

    Eyal Fitoussi
    Keymaster

    OK, my apologies as I just now realized that you are referring to the Members Directory page and not to GEO my WP search forms. And the code I provided you above is to be used with GEO my WP forms.

    I don’t see a way to add the members count to the Members Directory page without creating a custom function. I will look into adding this feature to the plugin while also looking into the other issue mentioned above.

    I will working on it within the next couple of days and see if I can release a solution.

    #52690

    Petra
    Participant

    Thanks a lot for such a quick reply. Please keep me posted.
    Good luck 🙂

    #52694

    Eyal Fitoussi
    Keymaster

    Will do, thanks.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Search not working correctly’ is closed to new replies.