Forum: Premium Settings

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Premium Settings premium extension please open a new premium support ticket.

[Resolved]Warnings in Member Global Map Form—options disabled

Home Forums Premium Settings Warnings in Member Global Map Form—options disabled

This topic contains 14 replies, has 2 voices, and was last updated by  charles sandner 4 years, 1 month ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #47016

    charles sandner
    Participant

    Default Map Icon and User Location Icon in the members global map form have warnings:

    Warning: Invalid argument supplied for foreach() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings/includes/admin/gmw-ps-admin.php on line 1420

    Warning: Invalid argument supplied for foreach() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings/includes/admin/gmw-ps-admin.php on line 1439

    So, these two options are disabled.

    I’m using GEO my WP 2.6.3

    GMW Glabal Maps 2.0

    GMW Premium Settings 1.6.2

    I’m using the X-Theme

    #47027

    Eyal Fitoussi
    Keymaster

    Hi Charles,

    Have you changed anything in the site that made these warnings show up? Any new plugins? updates? have you changed anything in the plugin files/folders structure?

    #47045

    charles sandner
    Participant

    This is a subdomain. A person was paid to design the original site, and built the entire thing on a bad platform. The site was basically junk.

    Now I’m redoing the site on a new theme, and putting the map functionality on my new subdomain.

    I did the original mapping function and all was fine.

    Now I can even display a members for or map either 🙁

    #47048

    charles sandner
    Participant

    This happens whenI try to display the map:

    Warning: Creating default object from empty value in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings-2/includes/gmw-ps-gmaps-functions.php on line 142
    Enter Address…

    7162 NE Ronler Way, Hillsboro, OR 97124, USA

    Fatal error: Call to undefined function gmw_fl_bp_groups() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-global-maps-2/friends/templates/search-forms/top-white/search-form.php on line 37

    #47052

    Eyal Fitoussi
    Keymaster

    I think there are some conflicts with the add-ons. I believe that you do not have the latest updates of the add-ons installed.

    Warning: Creating default object from empty value in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings-2/includes/gmw-ps-gmaps-functions.php on line 142
    Enter Address…

    This error was removed in one of the latest updates.

    Please go to Your Account page and verify that you have the latest versions of the add-ons installed. Anyway, I think it will be a good idea to just deactivate the add-ons, delete them and install the latest versions.

    Let me know if that helps.

    #47056

    charles sandner
    Participant

    I am using the latest versions from your site:

    GEO my WP 2.6.3

    GMW Glabal Maps 2.0

    GMW Premium Settings 1.6.2

    #47060

    Eyal Fitoussi
    Keymaster

    That’s weird, as I mentioned above the warning you see “Warning: Creating default object from empty value…” shouldn’t be there.

    I also see that the plugin’s folder name is gmw-premium-settings-2 when it should be just gmw-premium-settings.

    My advice is to remove all the add-ons that you have installed right now and re-install them with their original folders name. What you are experiencing looks like some sort of a conflict.

    #47070

    charles sandner
    Participant

    Ok, I redid everything. I removed all the plugins. I re-download them to insure the latest version of each. They now have the correct names.

    However, the result is the same-

    * Default Map Icon and User Location Icon in the members global map form have warnings:

    Warning: Invalid argument supplied for foreach() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings/includes/admin/gmw-ps-admin.php on line 1420

    Warning: Invalid argument supplied for foreach() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-premium-settings/includes/admin/gmw-ps-admin.php on line 1439

    * This is in the form (Profile Fields):

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘GMW_FL_Admin’ not found in /home/bustersvision/public_html/registry/wp-includes/plugin.php on line 503

    * when I try to display the form and map:

    Fatal error: Call to undefined function gmw_fl_bp_groups() in /home/bustersvision/public_html/registry/wp-content/plugins/gmw-global-maps/friends/templates/search-forms/compact/search-form.php on line 49

    #47111

    charles sandner
    Participant

    The hosting company (Godaddy) swears all is ok on their end.They compared another site I have on Godaddy where mapping worked correctly, as did I.Help, or I have ti redo the site in a new account, and start over again!

    #47112

    charles sandner
    Participant
    This reply has been marked as private.
    #47113

    charles sandner
    Participant
    This reply has been marked as private.
    #47139

    Eyal Fitoussi
    Keymaster

    I just looked at your site. The Members Locator add-on was deactivated. I activated it and the map is now showing.

    #47143

    charles sandner
    Participant

    Damn, I’m sorry I wasted your time. I feel dumber than I am. Thank you very much

    #47144

    Eyal Fitoussi
    Keymaster

    That’s ok :). Trust me, many times I spent so much time trying to find an issue which ended up being something as simple as that.

    #47146

    charles sandner
    Participant

    You won’t hear from me for a while as I’m on my way to get a frontal lobotomy. Again, thanks

    This issue is “Resolved”…if there ever was an issue. Gosh, Ive set this up successfully before too. THANKS…

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.