Forum: Geo Members Directory

This forum is closed for new topics. However, you can still search for a solution in the old topics. For technical support related to the Geo Members Directory premium extension please open a new premium support ticket.

[Resolved]Was working but now errors !

Home Forums Geo Members Directory Was working but now errors !

This topic contains 8 replies, has 2 voices, and was last updated by  Eyal Fitoussi 3 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #51254

    Website Ladies
    Participant

    Hey there,
    it was KINDA working for the past few days and this morning I woke up, didn’t change ANYTHING at all on the website, nothing, not even a new article and when I try to geo locate a member I have two errors :

    getCurrentPosition() and watchPosition() are deprecated on insecure origins, and support will be removed in the future. You should consider switching your application to a secure origin, such as HTTPS. See https://goo.gl/rStTGz for more details.

    and

    buddypress.min.js?ver=2.5.1:2 Uncaught TypeError: Cannot read property ‘split’ of undefined(anonymous function) @ buddypress.min.js?ver=2.5.1:2m.event.dispatch @ jquery.js?ver=1.11.3:4r.handle @ jquery.js?ver=1.11.3:4m.event.trigger @ jquery.js?ver=1.11.3:4e.event.trigger @ jquery-migrate.min.js?ver=1.2.1:2(anonymous function) @ jquery.js?ver=1.11.3:4m.extend.each @ jquery.js?ver=1.11.3:2m.fn.m.each @ jquery.js?ver=1.11.3:2m.fn.extend.trigger @ jquery.js?ver=1.11.3:4m.fn.(anonymous function) @ jquery.js?ver=1.11.3:5(anonymous function) @ md.min.js?ver=1.4.1:2

    #51257

    Website Ladies
    Participant

    Double post but I can’t edit the initial post :
    It is impossible to make the Geo My WP – Member Directory plugin working if the user is NOT an administrator. The themes breaks and repeats if the user is NOT an administrator.

    Then, if you put two users at the exact same location and the radius is 200 miles (whatever the distance in fact), the plugin doesn’t find anybody.

    Wherever they are in fact, it never finds anybody.

    ALSO, when the user is a NON administrator, the location doesn’t save in the “edit location part”, instead, after saving, it breaks the template, keeps on reloading and then make the template repeating. THIS with ALL TEMPLATES WHATEVER IT IS, even the WordPress bases.

    It is the second time I buy a licence, fortunately i don’t have to take care of the website of the other client anymore but DAMN, what a messy and expensive piece of trash with no support what so ever !

    All you have is answers from people of a FORUM that have NO CLUE of how the plugin works either, that tell you to try this or that and test your luck. Otherwise : no you need custom code.

    AND : no answer at any of my emails

    AND : of course, no refund, that would be too beautiful.

    Let’s scam people it is 2016 😉 Digital goods are not refundable.

    Trust me, nobody will torrent or pirate this. #LOL

    #51261

    Eyal Fitoussi
    Keymaster

    Hi,
    I do apologize for any issues you are having with the plugins and I will do my best to help you solve them ASAP.

    It is impossible to make the Geo My WP – Member Directory plugin working if the user is NOT an administrator. The themes breaks and repeats if the user is NOT an administrator.

    Then, if you put two users at the exact same location and the radius is 200 miles (whatever the distance in fact), the plugin doesn’t find anybody.

    Wherever they are in fact, it never finds anybody.

    ALSO, when the user is a NON administrator, the location doesn’t save in the “edit location part”, instead, after saving, it breaks the template, keeps on reloading and then make the template repeating. THIS with ALL TEMPLATES WHATEVER IT IS, even the WordPress bases.

    This is a live demo of the Members Directory add-on using Twenty Twelve theme ( default WordPress theme ). As you can see, the plugin is working and non of the issues you described is happening. I can also provide you with the username and password of one of the dummy users so you could see that the “Edit Location” is working as well.

    So, the fact that it is working well on my demo site and that no other users reported the issues that you did, leads me to believe that the issue cause by a specific conflict on your site. That could be a conflict with a theme, another plugin, a custom function you placed somewhere in your functions.php file and so on.

    Have you tried deactivating the other plugins to see if it is a conflict?

    Is it possible to provide me with a link to the site where I could see the issues you describe above?

    It is the second time I buy a licence, fortunately i don’t have to take care of the website of the other client anymore

    Your support is greatly appreciated. However, if you experienced these issues after purchasing the first license why didn’t you contact me to solve it before purchasing another license?

    but DAMN, what a messy and expensive piece of trash with no support what so ever !

    All you have is answers from people of a FORUM that have NO CLUE of how the plugin works either, that tell you to try this or that and test your luck. Otherwise : no you need custom code.

    Except for this topic you had two other topics:

    1) https://geomywp.com/forums/topic/custom-distance-radius/

    2) https://geomywp.com/forums/topic/auto-locate-when-clicking-on-an-icon/

    To both topics I replied within 24 hours. I am a single developer who is working on the development of the plugins and on the support forum. So I do believe that I had a clue of how the plugins work.

    To one of the topics I provide you with a solution. Or at least I hope I did but you didn’t reply to confirm. The other topic I did say that it needed to be custom coded. Unfortunately, even in 2016 developers are not smart enough to build the perfect plugin which can do everything that you want out of the box.

    AND : no answer at any of my emails

    Which emails? Did you mean the support tickets which I did reply to all ( as mentioned above )?

    AND : of course, no refund, that would be too beautiful.

    Based on my refund policy, if the plugins do not work and I cannot provide a solution, then I will provide you with a full refund. “stealing” your money was never my intention.

    Let’s scam people it is 2016 ? Digital goods are not refundable.

    Digital goods, usually, are not refundable if you simply decided “not to use it”. But my digital goods are refundable, within 30 days, if they are not working as described and I if I cannot provide a solution.

    Trust me, nobody will torrent or pirate this. #LOL

    Sadly, I don’t find this funny. I understand that you are upset and that the plugin you purchased might not be working as expected. However, it is working on my test site and it is working for the other users who purchased the plugin ( unless they don’t report issues ). So I do believe that it is a conflict caused by another plugin installed on your site.

    #51298

    Website Ladies
    Participant

    I am glad that you are here to answer, and give a REAL answer. I also apologize for this message, that of course is angry but this is so annoying to see how little things breaks down so easily.

    Is there any way I can have you look into my wordpress ? I also need a few custom changes that I believe is not too hard for you to trigger.

    A support ticket ? Else ?

    Can I have this ?

    best

    #51306

    Eyal Fitoussi
    Keymaster
    This reply has been marked as private.
    #51311

    Website Ladies
    Participant

    Hey there, can you please see the private content ?
    Thanks !

    Private Content Hidden
    #51318

    Website Ladies
    Participant

    EDIT PREVIOUS POST IN PRIVATE

    Private Content Hidden
    #51321

    Website Ladies
    Participant

    UPDATE !

    Alright, I found why it is not showing up : there is a button that says “All members” with a number on it. If you don’t click on it, it doesn’t display the users around !

    Do you know why ?

    I would like to remove it but I do, the information of the auto locate is not sent.

    If I hide it by css, it sends it but since you can’t see it to click on it, it doesn’t show the users by location.

    I know that it is here normally because you can show either all members or friends but I don’t have the friends thing activated. So it should just show everybody by location but it doesn’t want to !

    My credentials are in one of the previous PRIVATE post. If you could look that up it would already be a nice part solved !

    #51529

    Eyal Fitoussi
    Keymaster

    HI,
    I am marking this topic resolved since you have managed to get it all working ( as discussed via email ).

    If you have any other questions please feel free to start a new topic.

    Thanks,

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.